<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Men's basketball: To-do list leads Kalen Etzler to Ohio State</title><meta property=og:title content="Incoming freshman Kalen Etzler checked off to-do list that led to Ohio State"/><link rel=amphtml href=https://amp.buckeyextra.com/amp/7619866002 /><meta property=article:author content="Adam Jardy"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.buckeyextra.com /><link rel=preconnect href=https://user.buckeyextra.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=preconnect href=https://cdn.tinypass.com /><link rel=dns-prefetch href=//cdn.tinypass.com /><link rel=preconnect href=https://experience.tinypass.com crossorigin/><link rel=dns-prefetch href=//experience.tinypass.com /><link rel=preconnect href=https://buy.tinypass.com /><link rel=dns-prefetch href=//buy.tinypass.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.buckeyextra.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.buckeyextra.com/NBUX-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z357c67ab5.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z32ea41863.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=https://cdn.tinypass.com/api/tinypass.min.js /><meta name=description content="Convoy (Ohio) Crestview forward Kalen Etzler arrives on campus next weekend to start his Ohio State basketball career."/><meta property=og:description content="Convoy (Ohio) Crestview forward Kalen Etzler arrives on campus next weekend to start his Ohio State basketball career."/><meta property=fb:pages content=1510814149213454 /><meta property=fb:app_id content=1165617207137626 /><link rel=canonical href=https://www.buckeyextra.com/story/mens-basketball/2021/06/10/mens-basketball-do-list-leads-kalen-etzler-ohio-state/7619866002/ /><meta property=og:url content=https://www.buckeyextra.com/story/mens-basketball/2021/06/10/mens-basketball-do-list-leads-kalen-etzler-ohio-state/7619866002/ /><meta property=og:site_name content="Buckeye Xtra"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2020/11/14/NBUX/27e40e16-5e53-433d-8a61-fa73f6349aa1-IMG_9910.jpg?crop=2825,1589,x1104,y506&width=2825&height=1589&format=pjpg&auto=webp"/><meta property=og:image:width content=2825 /><meta property=og:image:height content=1589 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2020/11/14/NBUX/27e40e16-5e53-433d-8a61-fa73f6349aa1-IMG_9910.jpg?crop=2825,1589,x1104,y506&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@BuckeyeXtra /><meta name=twitter:creator content=@BuckeyeXtra /><meta name=twitter:title content="Incoming freshman Kalen Etzler checked off to-do list that led to Ohio State"/><meta name=twitter:description content="Convoy (Ohio) Crestview forward Kalen Etzler arrives on campus next weekend to start his Ohio State basketball career."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol><symbol id=gnt_svg_camera viewBox="0 0 24 24"><path d="M7 12.8a5 5 0 1 0 10 0 5 5 0 0 0-10 0zm9.33-6.02H20c1.1 0 2 .92 2 2.06v8.6c0 1.13-.9 2.06-2 2.06H4c-1.1 0-2-.93-2-2.07V8.84c0-1.14.9-2.06 2-2.06l3.67-.01c0-1.15.9-2.27 2-2.27h4.66c1.1 0 2 1.12 2 2.28zM12 16.8a4 4 0 1 1 0-8 4 4 0 0 1 0 8z"/></symbol><symbol id=gnt_svg_expand viewBox="0 0 24 24"><path d="M5 14v3.586l3.3-3.3L9.714 15.7l-3.3 3.3H10v2H3v-7zm16 0v7h-7v-2h3.586l-3.3-3.3 1.414-1.414 3.3 3.3V14zM10 3v2H6.414l3.3 3.3L8.3 9.714 5 6.414V10H3V3zm11 0v7h-2V6.414l-3.3 3.3L14.286 8.3l3.3-3.3H14V3z"/></symbol><symbol id=gnt_svg_sharelink viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#fff)><path d="M13.8625 8.5525c.3162.1924.615.424.8878.6972 1.8488 1.8486 1.849 4.857 0 6.7057l-3.6575 3.6578c-1.8488 1.849-4.8573 1.849-6.706 0-1.849-1.8488-1.849-4.8572 0-6.706l2.5346-2.5347c-.1966 1.1006-.0742 2.247.3688 3.2892l-1.0747 1.0745c-.8404.8404-.8404 2.2078 0 3.0482.8403.8404 2.2077.8404 3.0481 0l3.658-3.6578c.8404-.8403.8404-2.2077 0-3.0481a2.1379 2.1379 0 00-1.0172-.5676zm-.9551-4.1655c1.8487-1.8492 4.857-1.8492 6.7059 0 1.849 1.8486 1.849 4.8571 0 6.7057l-2.5346 2.535c.1964-1.1006.074-2.2468-.3688-3.289l1.0746-1.0748c.8404-.8404.8404-2.2078 0-3.0481-.8402-.8404-2.2078-.8404-3.0482 0l-3.6577 3.6577c-.8404.8402-.8404 2.2078 0 3.0482a2.136 2.136 0 001.0172.5676l-1.9582 1.9583a4.7251 4.7251 0 01-.888-.6972c-1.849-1.8485-1.849-4.8571 0-6.7057z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Buckeye Xtra" data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg preserveAspectRatio="xMinYMid meet" viewBox="0 0 285.64 41.9"><path d="M11.59 13.61c1.46-2.99 3.99-4.39 7.8-4.39 6.75 0 10.15 4.02 10.15 11.9 0 3.45-.57 5.91-1.75 7.94-1.65 2.79-4.72 4.39-8.36 4.39a10.7 10.7 0 01-5.53-1.41c-1.46-.9-2.18-1.84-2.79-3.73v4.44H.02V27.5h2.6V5.24H.02V0h11.57v13.61zm-.04 7.6c0 4.3 1.65 6.62 4.72 6.62 2.74 0 4.06-2.08 4.06-6.43 0-4.53-1.28-6.57-4.16-6.57-2.97 0-4.62 2.32-4.62 6.38zm36.85 7.32c-1.42 3.26-4.21 4.91-8.08 4.91-2.74 0-4.82-.8-6.28-2.41-1.23-1.37-1.6-2.55-1.6-5.29V15.17h-2.6V9.92H41.4v14.22c0 1.56.14 2.03.85 2.65.59.46 1.33.7 2.08.66 2.17 0 3.35-1.56 3.35-4.48v-7.8h-2.65V9.92h11.62v17.57h2.6v5.25H48.4v-4.21zm35.62-3.92c0 5.58-4.21 8.93-11.29 8.93-8.17 0-12.99-4.63-12.99-12.46 0-7.23 4.25-11.86 10.96-11.86 3.16 0 5.44 1.23 6.57 3.59v-2.9h6.76v8.97h-7.37c-.05-2.7-1.28-4.07-3.54-4.07-2.83 0-4.16 2.03-4.16 6.28 0 4.68 1.42 7.18 4.11 7.18 2.13 0 3.35-1.28 3.59-3.69l7.36.03zm27.82 3.29h2.22v4.82h-13.75V27.9h2.41l-3.02-4.98-3.87 2.79v2.2h2.08v4.82H84.58V27.5h2.63V5.24h-2.6V0h11.22v19.51l6.9-4.68h-4.02V9.92h14.74v4.91h-2.55l-4.96 3.6 5.9 9.47zm26.19-1.82c-1.41 4.98-5.2 7.37-11.57 7.37-7.79 0-12.38-4.58-12.38-12.28 0-7.42 4.53-11.96 11.96-11.96 5.24 0 8.97 1.94 10.68 5.48.85 1.7 1.37 4.68 1.37 7.47 0 .38 0 .66-.05 1.28h-15.38c.19 1.99.28 2.41.57 3.12.66 1.41 1.7 2.17 3.02 2.17 1.7 0 2.79-.85 3.26-2.65h8.52zm-8.38-7.18c-.19-3.54-1.14-4.98-3.35-4.98-2.22 0-3.31 1.56-3.55 4.98h6.9zm10.02-3.73h-1.7V9.92h13.42v5.25h-2.4l1.65 4.11a40.1 40.1 0 012.22 6.75c.61-2.88.9-3.87 2.36-7.89l1.13-2.99h-2.39V9.92h12.01v5.25h-1.65l-9.21 20.5c-2.22 4.98-4.02 6.23-9.17 6.23-1.28.02-2.57-.09-3.83-.33v-5.9c1.02.16 2.04.25 3.07.28 1.37 0 2.03-.43 2.65-1.8l.43-.8-8.59-18.18zm50.18 10.91c-1.41 4.98-5.2 7.37-11.57 7.37-7.8 0-12.38-4.58-12.38-12.28 0-7.42 4.53-11.96 11.96-11.96 5.24 0 8.97 1.94 10.67 5.48.85 1.7 1.37 4.68 1.37 7.47 0 .38 0 .66-.04 1.28h-15.37c.19 1.99.28 2.41.57 3.12.66 1.41 1.7 2.17 3.02 2.17 1.7 0 2.79-.85 3.26-2.65h8.51zm-8.37-7.18c-.19-3.54-1.14-4.98-3.36-4.98s-3.3 1.56-3.54 4.98h6.9z"/><path fill=#DA2227 d="M203.54 9.92v4.68h-2.08l3.11 3.87 3.45-3.87H206V9.92h11.25v5.25h-1.7l-5.49 5.76 6.09 6.57h1.49v5.25h-13.07v-4.72h2.49l-3.88-4.39-3.88 4.39h2.6v4.72h-11.69V27.5h1.46l6.13-6.57-5.48-5.76h-1.75V9.92h12.97zm26.98 15.92c0 1.65.28 2.22 1.23 2.22a1.4 1.4 0 001.33-1.09c.18-.9.25-1.82.19-2.74h4.72v1.33c0 5.48-2.41 7.89-7.89 7.89-5.91 0-8.55-2.6-8.55-8.36v-9.92h-3.11V9.92h3.11v-4.3l8.97-3.02v7.32h5.72v5.25h-5.71v10.67zm18.8-10.67c.61-1.84.76-2.13 1.46-3.02 1.49-1.94 3.26-2.93 5.24-2.93.83-.07 1.67.18 2.32.71v7.84a6.88 6.88 0 00-2.46-.42 6.45 6.45 0 00-3.88 1.23c-1.49 1.18-2.08 2.46-2.08 4.91v4.02h3.35v5.25h-14.95v-5.25h2.6V15.17h-2.6V9.92h10.96l.04 5.25zm10.49 1.98c.23-5.34 4.06-7.94 11.67-7.94 3.35 0 6.05.57 7.94 1.7 2.49 1.49 3.59 3.69 3.59 7.27v9.31h2.65v5.25h-10.1v-3.99c-1.75 3.31-4.21 4.68-8.13 4.68-5.38 0-8.69-2.83-8.69-7.37 0-2.83 1.56-5.2 4.3-6.52 1.84-.85 4.25-1.23 8.13-1.28 1.26.05 2.52.02 3.78-.09 0-2.36-.09-2.79-.61-3.45-.57-.75-1.46-1.13-2.83-1.13-2.27 0-3.21 1-3.35 3.54l-8.35.02zm14.31 5.27c-1.41-.02-2.82.09-4.21.33-1.89.47-2.93 1.49-2.93 2.99 0 1.6 1.14 2.55 3.07 2.55 3.02 0 4.68-1.89 5.1-5.81-.46-.06-.84-.06-1.03-.06z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.buckeyextra.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021JUNEFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.buckeyextra.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021JUNEFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/football/ data-t-l=:n|v|c|football elementtiming=nav-item>Football</a> <a class="gnt_n_mn_l gnt_n_mn_ce gnt_n_mn_l__se" href=/mens-basketball/ data-t-l=:n|v|c|mens-basketball>Men's Basketball</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/womens-basketball/ data-t-l=:n|v|c|womens-basketball>Women's Basketball</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/other-sports/ data-t-l=:n|v|c|other-sports>Other Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://www.osuphotostore.com/ data-t-l=:n|v|c|osu-photo-store>OSU Photo Store</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.dispatch.com/ data-t-l=:n|v|c|dispatch>Dispatch</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Columbus" title="Weather in Columbus" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.buckeyextra.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021JUNEFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a><div class=gnt_n_us_a_w data-g-r=nav_ce><a class="gnt_n_us_a gnt_n_mn_ce" href="https://login.buckeyextra.com/NBUX-GUP/authenticate?success-url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F&cancel-url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" data-g-r=nav_ab data-g-tn=navus data-t-l=":m|a|g|sign in / salutation" aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></a></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-oh-columbus-buckeyextra-C6771-high_impact-mens-basketball-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/mens-basketball/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/mens-basketball/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Mens-basketball data-c-ssts=MENS-BASKETBALL></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>Incoming freshman Kalen Etzler checked off to-do list that led to Ohio State</h1><div class=gnt_ar_by><a href=https://www.dispatch.com/staff/5701742002/adam-jardy/ class="gnt_ar_by_a gnt_ar_by_a__fi">Adam Jardy</a><div class=gnt_ar_pb>Buckeye Xtra</div></div><div class=gnt_ar_dt aria-label="Published 6:00 a.m. ET Jun. 10, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.buckeyextra.com/story/mens-basketball/2021/06/10/mens-basketball-do-list-leads-kalen-etzler-ohio-state/7619866002/ data-ss-t="Incoming freshman Kalen Etzler checked off to-do list that led to Ohio State" data-ss-d="Convoy (Ohio) Crestview forward Kalen Etzler arrives on campus next weekend to start his Ohio State basketball career."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1165617207137626&href=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F&text=Incoming%20freshman%20Kalen%20Etzler%20checked%20off%20to-do%20list%20that%20led%20to%20Ohio%20State&via=BuckeyeXtra" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Incoming%20freshman%20Kalen%20Etzler%20checked%20off%20to-do%20list%20that%20led%20to%20Ohio%20State%20-%20from%20Buckeye%20Xtra&body=Incoming%20freshman%20Kalen%20Etzler%20checked%20off%20to-do%20list%20that%20led%20to%20Ohio%20State%0A%0AConvoy%20(Ohio)%20Crestview%20forward%20Kalen%20Etzler%20arrives%20on%20campus%20next%20weekend%20to%20start%20his%20Ohio%20State%20basketball%20career.%0A%0ACheck%20out%20this%20story%20on%20buckeyextra.com%3A%20https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class=gnt_ar_b><figure class="gnt_em gnt_em__fp gnt_em_img"><img class=gnt_em_img_i style=height:495px src="https://www.gannett-cdn.com/presto/2020/11/14/NBUX/27e40e16-5e53-433d-8a61-fa73f6349aa1-IMG_9910.jpg?width=660&height=495&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image srcset="https://www.gannett-cdn.com/presto/2020/11/14/NBUX/27e40e16-5e53-433d-8a61-fa73f6349aa1-IMG_9910.jpg?width=1320&height=990&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Kalen Etzler, left, and coach and uncle Doug Etzler smile after the younger Etzler officially signed to play for Ohio State in a press conference at Convoy (Ohio) Crestview High School on November 11, 2020."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Kalen Etzler, left, and coach and uncle Doug Etzler smile after the younger Etzler officially signed to play for Ohio State in a press conference at Convoy (Ohio) Crestview High School on November 11, 2020." data-c-credit="Adam Jardy/The Columbus Dispatch"></div></figure><p class=gnt_ar_b_p>One by one, year by year, Kalen Etzler checked items off his to-do list.</p><p class=gnt_ar_b_p>As Etzler entered his freshman season at Convoy (Ohio) Crestview, one of his AAU coaches gave him an idea. If he wanted to be great, the coach said, he should write down what he wanted from the game in the next few years and look at it every day. Etzler did, setting the note as the background on his phone.</p><p class=gnt_ar_b_p>With a state championship? Check. Grab at least 15 rebounds in a game? Check. Record a triple-double? Triple-check.</p><p class=gnt_ar_b_p>Also on the list: <a href=/story/mens-basketball/2020/11/15/osu-basketball-kalen-etzler-signing-ohio-state-family-celebration/6289655002/ target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>playing Division I basketball in college</a>. It’ll be the last item checked off the list when he arrives at Ohio State during the weekend of June 18 to begin his freshman year after a senior season that unfolded mostly without incident amid the COVID-19 pandemic.</p><p class=gnt_ar_b_p>“I was just thankful because all year coach would tell us, you never know, we could get a call tomorrow and have to shut everything down,” Etzler said. “I didn’t want that to happen. Even though I was packaged up and ready to be shipped out to college, I obviously wanted to complete my high school season with all my friends.”</p><a class="gnt_em gnt_em_gl gnt_em__el" href=/picture-gallery/mens-basketball/2020/11/15/kalen-etzler-signs-play-ohio-state-2021-recruiting-class/6289912002/ data-t-l=":l|l|c|view gallery:inline promo" aria-label="View Gallery - Kalen Etzler signs to play for Ohio State in the 2021 class" data-g-r=nav_mo data-g-tn=pgcss data-g-mtn=pg6289912002 data-g-moh=hpgm aria-haspopup=dialog aria-expanded=false onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-c-id=6289912002><img class=gnt_em_gl_i data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2020/11/14/NBUX/af335af5-8397-47dc-97d0-c7e19bef2125-IMG_9903.jpg?crop=3017,1697,x653,y847&width=660&height=372&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2020/11/14/NBUX/af335af5-8397-47dc-97d0-c7e19bef2125-IMG_9903.jpg?crop=3017,1697,x653,y847&width=1320&height=744&format=pjpg&auto=webp 2x" decoding=async alt="" width=660 height=372 /><div class=gnt_em_gl_i_nt></div><div class=gnt_em_gl_vg data-c-tc=6><svg class=gnt_em_gl_vg_svg__ca><use xlink:href=#gnt_svg_camera /></svg><svg class=gnt_em_gl_vg_svg><use xlink:href=#gnt_svg_expand /></svg></div><div class="gnt_em_t gnt_em_t__hb" data-c-et="Kalen Etzler signs to play for Ohio State in the 2021 class" aria-label="Kalen Etzler signs his letter-of-intent to play for Ohio State in the 2021 recruiting class"></div></a><p class=gnt_ar_b_p>The Knights would fall in a district semifinal, but Etzler was named Division IV district player of the year and a first-team all-state selection after averaging 19.3 points per game. <a href=/story/mens-basketball/2021/01/22/ohio-state-signees-malak-branham-kalen-etzler-hit-scoring-milestones/4242963001/ target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>Along the way, he reached 1,000 career points</a>.</p><p class=gnt_ar_b_p>Just as important to Etzler, he got a full final season with his friends. Crestview would have one game canceled due to the pandemic, but it was able to be rescheduled. Its lone playoff win came on its home court, a first in school history.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-columbus-buckeyextra-C6771-native-article_link-mens-basketball-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>“We beat both of our rival schools,” he said. “One of my best friends, our post player, had 28 and that was real fun to watch. I was hoping he’d hit 30.”</p><p class=gnt_ar_b_p>Listed at 6-8, 180 pounds, Etzler is listed as a three-star power forward prospect, No. 150 nationally and No. 4 in Ohio according to the 247Sports.com composite database. Since committing to Ohio State in May, 2019, Etzler said that while he knows he will need to put on weight once he gets to college it’s not been something coach Chris Holtmann has told him to worry about.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-columbus-buckeyextra-C6771-native-article_link-mens-basketball-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>It’s an approach Etzler said he appreciated as he tried to enjoy his time at Crestview.</p><p class=gnt_ar_b_p>“I usually just eat small meals throughout the day,” he said. “It’s been hard trying to drink a lot of calories and burn the calories and put calories back on. My weight will anywhere from 178 to 185 every single day. It just goes up and down. It’s frustrating, but I trust that when I get there it’ll pack on pretty fast.”</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>That point was hammered home recently when Ohio State center Zed Key, who just completed his first season with the program, accompanied classmate Meechie Johnson Jr. to Etzler’s graduation party. Key, listed at 6-8, 245 pounds, wound up staying for an extra day, which got Etzler thinking.</p><p class=gnt_ar_b_p>“Someone of that size reminds me though that I need to put weight on soon,” Etzler said. “Zed coming down (recently) was really cool because I’m happy with the way we run things and how the culture is because Zed’s a really, really cool kid. He’s probably my best friend on the team thus far.”</p><p class=gnt_ar_b_p>Once he arrives, Etzler said he’s slated to be roommates with Johnson, Key and fellow freshman Malaki Branham.</p><p class=gnt_ar_b_p>“I’m really excited about them,” Holtmann said in mid-March when asked about Branham and Etzler. “Kalen has long-term potential, we feel like.”</p><p class=gnt_ar_b_p>Now it’s time for a new set of goals on bigger stage. But while Etzler crossed off most of that list from years ago, one remained.</p><p class=gnt_ar_b_p>“My goal was to score at least one 40-point game,” he said. “I just like sharing the wealth and I don’t want anyone to think I’m being selfish. Obviously I could go out and try to get 40, but who knows, maybe we go out and lose that game or it makes one of my teammates upset.”</p><p class=gnt_ar_b_p><em>ajardy@dispatch.com</em></p><p class=gnt_ar_b_p><em>@AdamJardy</em></p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.buckeyextra.com/story/mens-basketball/2021/06/10/mens-basketball-do-list-leads-kalen-etzler-ohio-state/7619866002/ data-ss-t="Incoming freshman Kalen Etzler checked off to-do list that led to Ohio State" data-ss-d="Convoy (Ohio) Crestview forward Kalen Etzler arrives on campus next weekend to start his Ohio State basketball career."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1165617207137626&href=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F&text=Incoming%20freshman%20Kalen%20Etzler%20checked%20off%20to-do%20list%20that%20led%20to%20Ohio%20State&via=BuckeyeXtra" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Incoming%20freshman%20Kalen%20Etzler%20checked%20off%20to-do%20list%20that%20led%20to%20Ohio%20State%20-%20from%20Buckeye%20Xtra&body=Incoming%20freshman%20Kalen%20Etzler%20checked%20off%20to-do%20list%20that%20led%20to%20Ohio%20State%0A%0AConvoy%20(Ohio)%20Crestview%20forward%20Kalen%20Etzler%20arrives%20on%20campus%20next%20weekend%20to%20start%20his%20Ohio%20State%20basketball%20career.%0A%0ACheck%20out%20this%20story%20on%20buckeyextra.com%3A%20https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-oh-columbus-buckeyextra-C6771-poster-mens-basketball-4 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.buckeyextra.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F&marketName=buckeyextra&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|notice our new look..." aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-columbus-buckeyextra-C6771-poster_scroll-mens-basketball-5 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/mens-basketball/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-oh-columbus-buckeyextra-C6771-leaderboard_btf-mens-basketball-6 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Buckeye Xtra - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.buckeyextra.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.buckeyextra.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://www.publicnoticesohio.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.buckeyextra.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.buckeyextra.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.buckeyextra.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.buckeyextra.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.buckeyextra.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/ohio/columbus/ class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.buckeyextra.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://help.buckeyextra.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://cm.buckeyextra.com/subscriberguide class=gnt_ft_a data-t-l=:f|v|c|support:subscriber-guide>Subscriber Guide</a> <a href=https://account.buckeyextra.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://cm.buckeyextra.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.buckeyextra.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.buckeyextra.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/buckeyextra class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=https://twitter.com/BuckeyeXtra class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a> <a href="http://nl.newsbank.com/nl-search/we/Archives?p_product=COLNP&p_theme=gatehouse&p_action=keyword" class=gnt_ft_a data-t-l=:f|v|c|stay-connected:archives>Archives</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.buckeyextra.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z32ea41863.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.buckeyextra.com/ data-t-l=":m|a|c|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.buckeyextra.com/user/enewspaper data-t-l=:m|a|c|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.buckeyextra.com/newsletters/manage/ data-t-l=:m|a|c|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.buckeyextra.com/pay data-t-l=":m|a|c|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.buckeyextra.com/delivery-issue data-t-l=":m|a|c|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.buckeyextra.com/delivery-temporary-stop data-t-l=":m|a|c|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.buckeyextra.com/subscriberguide data-t-l=":m|a|c|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.buckeyextra.com data-t-l=":m|a|c|help center">Help Center</a> <a class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" href="https://user.buckeyextra.com/NBUX-GUP/user/logout/?return-url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" data-t-l=":m|a|c|sign out">Sign Out</a></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon rel=nofollow href="https://login.buckeyextra.com/NBUX-GUP/authenticate?success-url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F&cancel-url=https%3A%2F%2Fwww.buckeyextra.com%2Fstory%2Fmens-basketball%2F2021%2F06%2F10%2Fmens-basketball-do-list-leads-kalen-etzler-ohio-state%2F7619866002%2F" data-t-l=":m|a|c|sign in">Sign In</a><div class=gnt_n_us_dd_lbl>Already have a print subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.buckeyextra.com/account-activation/ data-t-l=":m|a|c|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon rel=nofollow href="https://login.buckeyextra.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux" data-t-l=":m|a|c|create account">Create account</a></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><script type="gnt/tmpl" data-tmpl-key=pg6289912002><div class=gnt_em_mo_oy id=gnt_em_mo_oy role=dialog aria-modal=true aria-live=assertive aria-busy=true aria-roledescription=gallery><div class=gnt_em_mo data-g-r=nav_dd><button class=gnt_em_mo_xb data-g-r=nav_cl aria-label="Close Gallery"></button><div class=gnt_em_mo_ic><div class=gnt_em_mo_em></div><div class=gnt_em_mo_img_f><img class=gnt_em_mo_img alt="" usemap=#gnt_em_mo_mp /></div><map name=gnt_em_mo_mp class=gnt_em_mo_mp><area class="gnt_em_mo_mp_ar gnt_em_mo_mp_ar__pv" hidden coords="0 0 330 495" alt="" title="View Previous Image" tabindex=-1 aria-disabled=true /><area class="gnt_em_mo_mp_ar gnt_em_mo_mp_ar__nx" hidden coords="330 0 660 495" alt="" title="View Next Image" tabindex=-1 aria-disabled=true /></map><div class=gnt_em_mo_cn data-c-gc=6>1</div><button class="gnt_em_mo_pb gnt_em_mo_pb__pv" disabled aria-disabled=true aria-label="Previous image in gallery" aria-controls=gnt_em_mo_oy aria-keyshortcuts=ArrowLeft></button><button class="gnt_em_mo_pb gnt_em_mo_pb__nx" disabled aria-disabled=true aria-label="Next image in gallery" aria-controls=gnt_em_mo_oy aria-keyshortcuts=ArrowRight></button></div><div class=gnt_em_mo_tc><div class="gnt_ss gnt_em_mo_ss" data-g-r=base_sc data-ss-u=https://www.buckeyextra.com/picture-gallery/mens-basketball/2020/11/15/kalen-etzler-signs-play-ohio-state-2021-recruiting-class/6289912002/ data-ss-t="Kalen Etzler signs to play for Ohio State in the 2021 class" data-ss-d="Kalen Etzler signs his letter-of-intent to play for Ohio State in the 2021 recruiting class"><a class="gnt_ss_a gnt_em_mo_ss_a" href="https://www.facebook.com/dialog/share?display=popup&app_id=1165617207137626&href=https%3A%2F%2Fwww.buckeyextra.com%2Fpicture-gallery%2Fmens-basketball%2F2020%2F11%2F15%2Fkalen-etzler-signs-play-ohio-state-2021-recruiting-class%2F6289912002%2F" data-g-r=base_si data-ss-a=f data-t-l=":social share (gallery)|v|c|facebook" aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class="gnt_ss_a gnt_em_mo_ss_a" href="http://twitter.com/share?url=https%3A%2F%2Fwww.buckeyextra.com%2Fpicture-gallery%2Fmens-basketball%2F2020%2F11%2F15%2Fkalen-etzler-signs-play-ohio-state-2021-recruiting-class%2F6289912002%2F&text=Kalen%20Etzler%20signs%20to%20play%20for%20Ohio%20State%20in%20the%202021%20class&via=BuckeyeXtra" data-g-r=base_si data-ss-a=t data-t-l=":social share (gallery)|v|c|twitter" aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class="gnt_ss_a gnt_em_mo_ss_a" href="mailto:?subject=Kalen%20Etzler%20signs%20to%20play%20for%20Ohio%20State%20in%20the%202021%20class%20-%20from%20Buckeye%20Xtra&body=Kalen%20Etzler%20signs%20to%20play%20for%20Ohio%20State%20in%20the%202021%20class%0A%0AKalen%20Etzler%20signs%20his%20letter-of-intent%20to%20play%20for%20Ohio%20State%20in%20the%202021%20recruiting%20class%0A%0ACheck%20out%20this%20story%20on%20buckeyextra.com%3A%20https%3A%2F%2Fwww.buckeyextra.com%2Fpicture-gallery%2Fmens-basketball%2F2020%2F11%2F15%2Fkalen-etzler-signs-play-ohio-state-2021-recruiting-class%2F6289912002%2F" data-t-l=":social share (gallery)|v|c|email" aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><a class="gnt_ss_a gnt_em_mo_ss_a" href=https://www.buckeyextra.com/picture-gallery/mens-basketball/2020/11/15/kalen-etzler-signs-play-ohio-state-2021-recruiting-class/6289912002/ target=_blank rel=noopener data-t-l=":social share (gallery)|v|c|sharelink" aria-label="Standalone gallery page"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_sharelink /></svg></a><button class="gnt_ss_a gnt_ss_a__sa gnt_em_mo_ss_a" data-g-r=base_si data-ss-a=s data-t-l=":social share (gallery)|v|c|shareapi" aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class=gnt_em_mo_cc><div class="gnt_em_mo_cap gnt_em_mo_cc__swd"></div><div class="gnt_em_mo_crd gnt_em_mo_cc__swd"></div></div></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pglbl gnt_x__lg"><div id=ad-slot-7103-oh-columbus-buckeyextra-C6771-leaderboard_gallery_companion-mens-basketball-1 class="gnt_x_lb gnt_x_lb__lg"></div></aside><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pglbl gnt_x__pg"><div id=ad-slot-7103-oh-columbus-buckeyextra-C6771-poster_gallery_companion-mens-basketball-1 class=gnt_x_pg></div></aside></div></div></script><script type="gnt/tmpl" data-tmpl-key=pgcss>|styles|.gnt__mo{overflow:hidden;margin-right:var(--gnt-sw,0);pointer-events:none;-webkit-user-select:none;user-select:none}.gnt_em_mo_oy{overscroll-behavior:contain;overflow:auto;contain:strict;display:flex;flex-wrap:wrap;position:fixed;z-index:2147483647;top:0;left:0;width:100%;height:100%;background:#000;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;pointer-events:auto}.gnt_em_mo_xb{position:absolute;z-index:1;top:20px;right:20px;width:44px;height:44px;margin:0;border:4px solid #fff;border-radius:50%;background:#303030;touch-action:manipulation;cursor:pointer}.gnt_em_mo_xb::before{content:'';position:absolute;top:17px;left:10px;transform:rotate(45deg);width:16px;height:2px;background:#fff}.gnt_em_mo_xb::after{content:'';position:absolute;top:17px;left:10px;transform:rotate(-45deg);width:16px;height:2px;background:#fff}.gnt_em_mo_xb:hover{background:#000}.gnt_em_mo{contain:layout;display:flex;justify-content:center;position:relative;width:980px;height:676px;margin:auto;padding:30px 10px 20px 14px;background:#000;color:#fff}.gnt_em_mo_ic{contain:layout size;display:flex;flex-flow:wrap;align-content:start;width:660px}.gnt_em_mo_em{contain:strict;display:none}.gnt_em_mo_em[data-c-et]{display:flex;flex-flow:column;justify-content:center;width:500px;height:495px;margin:0 80px -495px;font:700 20px/26px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-align:center}.gnt_em_mo_em::before{content:attr(data-c-et)}.gnt_em_mo_em::after{content:attr(data-c-eb);margin:20px 0;font-weight:400;font-size:16px;line-height:20px}.gnt_em_mo_img_f{will-change:contents;contain:strict;transform:translate3d(0,0,0);width:660px;height:495px;margin:0 0 20px}.gnt_em_mo_img{contain:content;visibility:visible!important;opacity:0;display:block;object-fit:contain;width:660px;height:495px}.gnt_em_mo_img[srcset]{opacity:1}.gnt_em_mo_mp{touch-action:manipulation}.gnt_em_mo_mp_ar:not([hidden]){touch-action:manipulation;cursor:pointer}.gnt_em_mo_cn{will-change:contents;contain:strict;transform:translate3d(0,0,0);width:120px;margin:0 16px 0 154px;font:700 16px/36px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-rendering:optimizeLegibility;text-align:right;pointer-events:none}.gnt_em_mo_cn::after{content:' OF ' attr(data-c-gc);color:#c2c2c2}.gnt_em_mo_pb{will-change:background;contain:strict;transform:translate3d(0,0,0);width:36px;height:36px;margin:0 2px;padding:0;border:0;background:#1665cf;touch-action:manipulation;cursor:pointer}.gnt_em_mo_pb::before{content:'';display:inline-flex;height:4px;width:4px;margin:7px 0 7px 7px;padding:2.5px;border-right:2px solid #fff;border-bottom:2px solid #fff;transform:rotate(135deg)}.gnt_em_mo_pb__nx::before{margin-left:-4px;transform:rotate(-45deg)}.gnt_em_mo_pb:hover{background:#0a32a0}.gnt_em_mo_pb:disabled{background:#404040;cursor:default}.gnt_em_mo_tc{contain:layout size;display:flex;flex-flow:column;width:300px;margin:49px 0 0 20px}.gnt_em_mo_ss{contain:layout size;transform:translate3d(0,0,0);width:225px;height:30px;margin:-52px 0 22px -8px}.gnt_em_mo_ss_a{--gnt-sfc:#FFF;margin:0 11px 0 5px;padding:3px;font-size:24px}.gnt_em_mo_ss_a:hover{--gnt-sfc:#E0E0E0}.gnt_em_mo_cc{will-change:contents;contain:strict;transform:translate3d(0,0,0);width:300px;height:356px;-webkit-user-select:text;user-select:text}.gnt_em_mo_cap{margin:0 0 16px;font:16px/20px 'Georgia Pro',Georgia,'Droid Serif',serif;text-rendering:optimizeLegibility}.gnt_em_mo_crd{font:italic 12px/14px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-rendering:optimizeLegibility}.gnt_em_mo_cc__swd:empty{display:none}.gnt_em_mo_cap_a{color:#fff;text-decoration:underline;text-decoration-color:#0098fe;text-decoration-thickness:2px;text-underline-offset:2px}.gnt_em_mo_cap_a:hover{color:#c2c2c2}.gnt_x__lg{display:none}.gnt_x__pg{contain:layout size;position:absolute;bottom:20px;right:10px;width:300px;height:268px;margin:0}.gnt_x_pg{contain:strict;overflow:hidden;transform:translate3d(0,0,0);width:300px;height:250px;background:#262626}.gnt_x__pglbl::before{color:#fff}@media (min-width:1200px){.gnt_em_mo_oy{background:rgba(0,0,0,.8)}.gnt_em_mo_xb{right:-20px}.gnt_em_mo{width:1020px;padding:30px 60px 34px}.gnt_em_mo_tc{margin:49px 0 0 60px}.gnt_x_lb__lg{background:#262626}.gnt_x__lg{contain:layout size;display:block;position:absolute;left:26px;bottom:34px;width:728px;height:108px;margin:0}.gnt_x__pg{bottom:34px;right:60px}}@media (min-height:780px){.gnt_em_mo_xb{top:-20px}}</script><script async src=/tangstatic/js/pg-q1a2z397e7b0b0.min.js></script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3j4S1QXUxvuptpfmfNc8oW9MR4yk.min.json /><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/tangsvc/pg/6289912002/ /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"Incoming freshman Kalen Etzler checked off to-do list that led to Ohio State","description":"Convoy (Ohio) Crestview forward Kalen Etzler arrives on campus next weekend to start his Ohio State basketball career.","url":"https://www.buckeyextra.com/story/mens-basketball/2021/06/10/mens-basketball-do-list-leads-kalen-etzler-ohio-state/7619866002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.buckeyextra.com/story/mens-basketball/2021/06/10/mens-basketball-do-list-leads-kalen-etzler-ohio-state/7619866002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2020/11/14/NBUX/27e40e16-5e53-433d-8a61-fa73f6349aa1-IMG_9910.jpg?crop=2906,2906,x725,y118&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/11/14/NBUX/27e40e16-5e53-433d-8a61-fa73f6349aa1-IMG_9910.jpg?crop=2825,1589,x1104,y506&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-06-10T10:00:15Z","dateCreated":"2021-06-10T10:00:15Z","dateModified":"2021-06-10T10:00:15Z","articleSection":"mens-basketball","publisher":{"@type":"Organization","name":"Buckeye Xtra","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/buckeyextra/images/site-nav-logo@2x.png"}},"author":["Adam Jardy"],"keywords":["access:metered","ssts:mens-basketball","type:story","tag:Ohio State Buckeyes","tag:Overall Neutral","tag:Basketball recruiting","tag:Big Ten Conference","tag:Men's College Basketball"],"isAccessibleForFree":false,"hasPart":{"@type":"WebPageElement","isAccessibleForFree":"False","cssSelector":".gnt_ar_b"},"isPartOf":{"@type":["CreativeWork","Product"],"name":"Buckeye Xtra - Unlimited Digital Access","productID":"buckeyextra.com:standard"},"metadata":"{\"id\":\"7619866002\",\"siteCode\":\"NBUX\",\"contentSourceCode\":\"NBUX\",\"ssts\":\"mens-basketball\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/11/14/NBUX/27e40e16-5e53-433d-8a61-fa73f6349aa1-IMG_9910.jpg","caption":"Kalen Etzler, left, and coach and uncle Doug Etzler smile after the younger Etzler officially signed to play for Ohio State in a press conference at Convoy (Ohio) Crestview High School on November 11, 2020.","copyrightHolder":"Adam Jardy/The Columbus Dispatch"}]</script></body></html>